Disable checking for updates and WordPress plugins

(No ratings yet)
Загрузка ... Loading ...

Update WordPress plugins and need.

I do not argue.

This has several advantages: new features, user-friendly interface (for someone like), security, etc. But, the new version each time becoming gluttonous on server system resources. This is an obvious flaw, which is often the deciding factor in choosing: to upgrade or not to upgrade.

For those who do not want to be constantly updated, but is afraid that "goes wrong" because of the annoying reminders in the admin panel, I suggest disable the reminder that your version of WP is outdated and it's time to upgrade.

To do this, you can use plugins, but I advise you to go another way.

Just add the file to your theme's functions.php the following lines.

To disable updates WordPress, depending on the currently installed version, insert:

 add_action ( 'init' , create_function ( '$a' , "remove_action( 'init', 'wp_version_check' );" ) , 2 ) ; add_filter ( 'pre_option_update_core' , create_function ( '$a' , "return null;" ) ) ; # <? Php # 2.3 to 2.7: add_action ('init', create_function ('$ a', "remove_action ('init', 'wp_version_check');"), 2); add_filter ('pre_option_update_core', create_function ('$ a ', "return null;")); #  ; ?> null; "));?> 

To disable the update check plugin insert:

  <? Php
 # 2.3 to 2.7: 
  , create_function ( '$a' , "remove_action( add_action ('admin_menu', create_function ('$ a', "remove_action ( 
  ; 'Load-plugins.php', 'wp_update_plugins'); "));
 , create_function ( '$a' , "remove_action( add_action ('admin_init', create_function ('$ a', "remove_action ( 
  , 2 ) ; 'Admin_init', 'wp_update_plugins'); "), 2);
 , create_function ( '$a' , "remove_action( add_action ('init', create_function ('$ a', "remove_action ( 
  , 2 ) ; 'Init', 'wp_update_plugins'); "), 2);
 , create_function ( add_filter ('pre_option_update_plugins', create_function (
 "return null;" ) ) ; '$ A', "return null;"));

 # 2.8: 
  , 'wp_update_plugins' ) ; remove_action ('load-plugins.php', 'wp_update_plugins');
 , 'wp_update_plugins' ) ; remove_action ('load-update.php', 'wp_update_plugins');
 , '_maybe_update_plugins' ) ; remove_action ('admin_init', '_maybe_update_plugins');
 , 'wp_update_plugins' ) ; remove_action ('wp_update_plugins', 'wp_update_plugins');
 , create_function ( '$a' , add_filter ('pre_transient_update_plugins', create_function ('$ a',
 ; "Return null;"));
 ?> 

That's basically it. I recall only that it is better to edit files using the program Notepad2 . Encoding better put UTF-8 (although in this case in principle).

Last modified: 10/08/2013 at 08:00
Published: Tuesday, August 25, 2009 at 18:50
Choose the language:

Comments: 10

Average bar: 4.96 out of 5
  1. francis
    September 18th, 2009 at 14:19

    Your code does not work: a lot of errors (parse error, etc.)
    Do you have an explanation?
    I've never seen this before.

    Reply

  2. Ai Pi Mani
    September 18th, 2009 at 14:20

    francis, please refer to the original page: http://www.ipmoney.info/?p=122

    Reply

  3. francis
    September 18th, 2009 at 14:24

    Excuse me!
    I'm sorry.
    I watched the translation page.
    In French, it is transformed code.
    Sorry again, and my gratitude for your contribution!

    Reply

  4. overbag
    September 15th, 2010 at 18:03

    How to disable updating the theme?

    Reply

  5. Design blog
    December 3, 2010 at 12:47

    What is $ a in the code? Where can I get it?

    Reply

  6. Ai Pi Mani
    December 5th, 2010 at 12:25

    Design blog, just add the file to your theme's functions.php line given in the article.

    Reply

  7. LexaYa
    February 13, 2011 at 23:43

    And if you update wordpress, all files are deleted and the article?

    Reply

  8. leonking
    February 21, 2011 at 11:40

    Good day! I'm working on WordPress 3.0.5, if you know how to disable checking in this version. Thank you.

    Reply

  9. Hyper
    April 19, 2011 at 05:40

    Keep the last question. Also interested in checking off wp 3.xx

    Reply

  10. Hyper
    September 25th, 2011 at 09:44

    Is not that the way?

    Reply

Have something to say? Do not be silent!


Your comment will appear after being moderated.
Spam and off-topic posts are deleted.

To insert php-code, use the tag:
<pre lang="php"> php-code </ pre>


I'm not a spammer!