Masquer la version de WordPress

(Pas encore de note)
Загрузка ... Chargement en cours ...

Récemment, j'ai discuté de certaines des façons de protéger blog WordPress . Aujourd'hui, je veux partager avec vous un moyen de cacher la version de WP contre les intrus.

Le fait que vous connaissiez la version du hacker WP moteur peut facilement trouver une «clé» de votre trésor et de les gérer comme vous voulez, je ne vais pas parler. Procéder immédiatement à la défense.

1. fichier functions.php dans le dossier de votre thème.
Ajoutez la ligne

  'wp_head' , 'wp_generator' ) ; ?> <Php remove_action ('wp_head', 'wp_generator');?> 

2. Header.php déposer dans le dossier de votre thème.
Retirez la ficelle

  <Meta name = contenu "générateur" = "WordPress <? Php
 ) ; ?> " /> bloginfo ('version');?> "/> 

3. Fichiers readme.html License.txt et le dossier dans korenvoy WordPress.
Supprimer ces fichiers totalement.

4. Fichiers:
feed-atom-comments.php
feed-atom.php
feed-rdf.php
feed-rss.php
feed-rss2-comments.php
feed-rss2.php
feed.php
dans le dossier / wp-includes
Dans chacun de ces fichiers, supprimez la ligne

  $wp_version ?> " --> <! - Générateur = "? Wordpress / <php echo $ wp_version>?" -> 

et

  <Générateur uri = version "http://wordpress.org/" = "<? Php
 ) ; ?> ">WordPress</generator> bloginfo ('version');?> "> WordPress </ generator> 

Le feed-rdf.php 22 ligne du fichier est

  <Administrateur: generatorAgent rdf: resource = "http://wordpress.org/?v = <Php
 ?> "/> echo $ wp_version?> "/> 

Retirez-le.

En suivant ces étapes simples vous cacher la version de WordPress particulièrement curieux. Je voudrais aussi noter que si vous utilisez pour diffuser leur service RSS-feeds FeedBurner, la quatrième étape va vous aider.

Dernière mise à jour: 08/06/2013 à 01:05
Publié: Lundi 8 Juin 2009 à 14:49
Choisissez la langue:

Commentaires: 9

Bar moyenne: 4,92 sur 5
  1. Alexander
    17 juin 2009 à 20:08

    Il est écrit dans un tas de blogs.

    Répondre

  2. richkeeper
    18 juin 2009 à 02:25

    Oui, toujours la dupe. Mais je ne recommanderais pas une balise meta pour effacer.

    Répondre

  3. Ai Pi Mani
    18 juin 2009 à 05:39

    richkeeper, veuillez justifier.

    Répondre

  4. Aleksandr
    27 juin 2009 à 23:30

    Que pouvez-vous dire au sujet de la nouvelle version 2.8 et sa sécurité? Si vous pensez que oui, alors, en principe, le code est plein de trous ...

    Répondre

  5. BL
    27 juin 2009 à 23:32

    Quant à moi, la chose la plus importante est que la base de données n'est pas obtenu melon, et la reconstruction du reste.

    Répondre

  6. Web Design
    20 septembre 2009 à 21:02

    À mon avis, il est plus facile de mettre à niveau WordPress. Bien sûr, il faudra plus de temps, mais les dernières versions de WordPress est mise à jour directement depuis le panneau d'administration et prend moins d'une minute.

    Répondre

  7. Azamat
    18 mai 2011 à 11:07

    Je suis un blogueur débutant et j'ai besoin de cette information a été utile! Je vous remercie!

    Répondre

  8. Simple
    28 août 2011 à 11:18

    À mon avis, un poste normal. :)

    Répondre

  9. Serge
    25 octobre 2011 à 18:34

    Bon post - a jeté à nouveau un signet, visite de soi.

    Répondre

Vous avez quelque chose à dire? Ne pas se taire!


Votre commentaire apparaîtra après avoir été modéré.
Spam et les messages hors sujet seront supprimés.

Pour insérer code PHP, utilisez la balise:
<pre lang="php"> php-code </ pre>


Je ne suis pas un spammeur!