Nascondere la versione di WordPress

(Ancora nessuna valutazione)
Загрузка ... Caricamento in corso ...

Recentemente, ho discusso alcuni dei modi per proteggere i blog WordPress . Oggi voglio condividere con voi un modo per nascondere la versione di WP da intrusi.

Il fatto che si conosce la versione di WP dell'hacker motore può facilmente trovare una "chiave" per il tuo tesoro e gestirli come vuoi non parlerò. Procedere immediatamente alla difesa.

1. Del file functions.php nella cartella con il vostro tema.
Aggiungere la riga

  'wp_head' , 'wp_generator' ) ; ?> <Php remove_action ('wp_head', 'wp_generator');??> 

2. Header.php file nella cartella con il vostro tema.
Rimuovere la stringa

  <Meta name = contenuto di "generatore" = "WordPress <? Php
 ) ; ?> " /> bloginfo ('version');?> "/> 

3. File readme.html License.txt e cartelle in korenvoy WordPress.
Eliminare completamente i file.

4. File:
feed-atomo-comments.php
feed-atom.php
feed-rdf.php
feed-rss.php
feed-Rss2-comments.php
feed-rss2.php
feed.php
nella cartella / wp-includes
In ognuno di questi file, cancellare la riga

  $wp_version ?> " --> <-! Generator = "? Wordpress / <php echo $ wp_version>?" -> 

e

  <Generator uri = versione "http://wordpress.org/" = "<? Php
 ) ; ?> ">WordPress</generator> bloginfo ('version');?> "> WordPress </ generator> 

Il feed-rdf.php linea 22 del file appare

  <Amministrazione: generatorAgent rdf: resource = "http://wordpress.org/?v = <Php
 ?> "/> echo $ wp_version?> "/> 

Rimuoverlo.

Seguendo questi semplici passi potrete nascondere la versione di WordPress particolarmente curioso. Vorrei anche notare che se si utilizza per trasmettere il loro servizio di feed RSS FeedBurner, il quarto passo vi aiuterà.

Ultima modifica: 08/06/2013 alle 02:39
Pubblicato: Lunedi June 8, 2009 a 14:49
Scegli la lingua:

Commenti: 9

Bar media: 4,92 su 5
  1. Alexander
    17 giugno, 2009 alle 20:08

    E 'scritto in un mucchio di blog.

    Rispondere

  2. richkeeper
    18 giu 2009 alle 02:25

    Sì, ancora la vittima. Ma io non consiglierei un meta tag da cancellare.

    Rispondere

  3. Ai Pi Mani
    18 giu 2009 alle 05:39

    richkeeper, si prega di giustificare.

    Rispondere

  4. Aleksandr
    27 Giu 2009 alle 23:30

    Cosa si può dire circa la nuova versione 2.8 e la sua sicurezza? Se pensate così, allora in linea di principio il codice è pieno di buchi ...

    Rispondere

  5. BL
    27 Giu 2009 alle 23:32

    Quanto a me, la cosa più importante è che il database non è avuto melone, e la ricostruzione di tutto il resto.

    Rispondere

  6. Web Design
    20 settembre 2009 alle 21:02

    A mio avviso, è più facile da aggiornare WordPress. Certo, ci vorrà più tempo, ma le ultime versioni di WordPress viene aggiornato direttamente dal pannello di amministrazione e richiede meno di un minuto.

    Rispondere

  7. Azamat
    18 maggio 2011 alle 11:07

    Io sono un blogger principiante e ho bisogno di questa informazione è stata utile! Grazie!

    Rispondere

  8. Semplice
    28 agosto 2011 alle 11:18

    A mio parere, una carica normale. :)

    Rispondere

  9. Serge
    25 ottobre 2011 alle 18:34

    Buon post - gettò di nuovo un segnalibro, visita stima.

    Rispondere

Avete qualcosa da dire? Non tacere!


Il tuo commento verrà visualizzato dopo essere stato moderato.
Spam e messaggi off-topic verranno eliminati.

Per inserire php-codice, utilizzare il tag:
<pre lang="php"> php-codice </ pre>


Io non sono uno spammer!